HomeMade
Trx Wolf - Wersja do druku

+- HomeMade (http://sp-hm.pl)
+-- Dział: Urządzenia nadawczo odbiorcze KF (/forum-62.html)
+--- Dział: Transceivery HomeMade (/forum-64.html)
+--- Wątek: Trx Wolf (/thread-4266.html)

Strony: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31


RE: Trx Wolf - SP9OYN - 16-07-2022 18:14

Dzięki Krzysztof, o takie szacunki mi chodziło.


RE: Trx Wolf - SP5TAA - 26-07-2022 13:32

Witam kolegów, potrzebuję pomocy znawców tematu...
Dobrnąłem wreszcie do najciekawszego momentu kiedy przychodzi pora zalewania oprogramowania.
Zabrałem się za zalanie wsadu do STM`a i spotkała mnie niespodzianka w postaci takiego komunikatu "read out protection actyvaited" a po potwierdzeniu aby ten read out usunąć i zaprogramować mimo to mikrokontroler, kolejny komunikat o niepowodzeniu akcji a na koniec "the elf loader not acceseble" lub coś takiego- piszę z pamięci.
Pytanie softwareowego laika, czyżby problem z STM`em?
Dodam tylko że używam ST-LINK V2.


RE: Trx Wolf - SP6AUO - 26-07-2022 16:11

Witaj Witku.
Robię tak:
1.Podłączam do komputera.(przy okazji czytam prąd =330mA WIN10)
[attachment=17786]
2.Uruchamiam program
[attachment=17787]
3.Wczytuję wsad (3.50)
[attachment=17788]
4.Klikam Target Connect
[attachment=17789]
5.W prawym górnym rogu pojawiają się dane procesora (komp widzi STM-a)
[attachment=17790]
6.Klikam Target Program i następuje wczytanie wsadu.
[attachment=17791]
7.Leci wsad do stm
[attachment=17792]
8.Wleciał
[attachment=17793]
Specjalnie Witek dla Ciebie powtórzyłem procedurę programowania.


RE: Trx Wolf - SP5TAA - 26-07-2022 16:30

Dzięki Ci Andzrzej za włożony trud, wszystko było by tak jak na Twoich zrzutach do momentu gdy robię conect , programator nie widzi flash pamięci, skiegoś czorta wzięło się to zabezpieczenie odczytu, a na koniec tych prób dostaję ten komunikat: "the elf loader file is not accessible" ...no i w tym jest zagwozdka - czekam na podpowiedź lub wyjaśnienie softwarowych speców...tak przy okazji, Altera "łyka" każdy wsad bez najmniejszego zająknięcia.


RE: Trx Wolf - SP6AUO - 26-07-2022 18:34

Witek,a prąd jaki masz przed programowaniem.
Z innej beczki. Jaki T3 zastosowałeś za 1:1+1.Może ktoś ustalił jaki ma być.
Dalej mam wątpliwości co do T3. 1:1,czy 1:2.
Mam jeszcze taki problem, dwa transformatorki 1:1 tyle,że jeden na pinach 3-6 ma 92uH a drugi
na pinach 3-6 ma 36uH.Który wlutować ? oba podają 0.3 - 400MHz.
Jutro zajmę się Alterą. T3 i Altera to ostatnie elementy na tej pcb.


RE: Trx Wolf - SP5TAA - 27-07-2022 10:46

Witam Cię Andrzej,
na początek powiem tak, ta wersja którą ja robię(WF-100D) ma nieco inne oznaczenia elementów i to trafko T3 u mnie to T2 i ja mam tam 1:1 z odczepem na środku wtórnego(pytałem autora tego projektu, który potwierdził mi że to co ja mam
-PWB-1-ALC może być zastosowane w tym miejscu).
Z moim ST-LINK V2 w żaden sposób nie mogę zaprogramować STM`a - ciągle dostaję komunikat o aktywowanych "read out protection", coś udaje się z pomocą Cubeprogrammer.
Wojowałem wczoraj z dziwnymi efektami na wyświetlaczu(efekty takie jakby gdzieś był niepewne połączenia lub brak kontaktu), próbując ustalić miejsce problemów - u mnie elementy z płytki display`a i sam display są przeniesone na nową płytę front panela...
Kojarzę że prąd był też coś około 330mA ale z diabła nie pamiętam czy to wartość przed programowanie czy po uruchomieniu modułu main board(bez LTC2208).
Dziś daję sobie wolne od tej "wojaczki"...


RE: Trx Wolf - SP6AUO - 27-07-2022 15:43

Witek,chodzi mi o T3 na mainboard pod alterą koło J9.
Ten opisany jako 1:1+1
Chyba wlutuję typowy 1:1.
Na schemacie jak strzałka mojej myszy.
[attachment=17794]


RE: Trx Wolf - SP5TAA - 27-07-2022 16:52

Cześć, tak, tak, o tym samym mówimy, u mnie stoi 1:1, o czym już mówiłem.
Jak tam u Ciebie z Alterą, siedzi już na swoim miejscu?...


RE: Trx Wolf - SP6AUO - 27-07-2022 18:08

Altera jeszcze czeka.
Mam jeszcze pytanie.
Jak próbujesz wgrywać do STM-a z zasilacza komputerowego czy z zasilacza ogólnego Wolfa.
W opisie jest ,że włącz power i trzymaj.Nawet tak nie próbowałem.
Na 1-szym zrzucie jest pokazane połączenie gniazda jtag_stm z moim Win10.
Trochę jest niepokojący ten komunikat który Ci wyskakuje.
Ja zawsze kontroluję prąd.
Bez STM-a był tam ileś.Po wlutowaniu STM prąd wzrósł o niecałe 20mA (chyba 16mA).
Po wgraniu wsadu prąd wzrósł o 70mA (około)Już wiedziałem,że jest ok.
Po podłączeniu do pcb czołowej na ekranie pojawiły się różowe prążki.Trwało to 18-20 minut i wskoczył normalny widok
7MHz.Może coś pomoże.


RE: Trx Wolf - SP5TAA - 27-07-2022 21:01

Witam, dzisiaj dałem se wolne od tematu oprogramowania...
Korzystam z zasilacza docelowego, zamiast ciągłego naciskania przycisku PWR założyłem dżamper na złączu do tego przycisku.
Dzisiaj śledzę podobne tematy do mojego przypadku, koledzy opisują to na Telegramie.